Help
cancel
Showing results for 
Search instead for 
Did you mean: 
Ground Controller Lvl 1
Message 1 of 1

QGIS3.8 Hotspot Analysis Plugin not installing

I'm not sure if I'm posting this in the right place but I'm hoping someone on here might be able to help me. I'm fairly new to this whole programming world and I'm completely lost. For my PhD project I have to use QGIS to produce georeferenced heatmaps based on informants' hand-drawn maps. An academic from another institution has provided me with step-by-step instructions of what to install and the steps to follow, but I've hit a big problem with installing the Hotspot Analysis plugin in QGIS.

I am working on a Macbook. So far I have installed Python, as well as pip, numpy, scify, and pysal (as instructed). However, when I try to install the Hotspot Analysis plugin I keep getting this same error message:

 

Couldn't load plugin 'HotspotAnalysis' due to an error when calling its classFactory() method

ModuleNotFoundError: No module named 'pysal.esda'

 

Does anyone have any idea how to rectify this? I've tried uninstalling and reinstalling everything. I've also tried installing the plugin from a zip file, but I still get the same message. Pysal is installed, so I don't know why it's not working.