Help
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Ground Controller Lvl 1
Message 21 of 29

Re: pages user site not published

Same happend with my site, thank God I saw this post and my problem is solved

Ground Controller Lvl 1
Message 22 of 29

Re: pages user site not published

Same Thing happened to my hosted site too. Page not found. How do I fix this?

Highlighted
Ground Controller Lvl 2
Message 23 of 29

Re: pages user site not published

You can publish your other repositories as well using Github pages but the domain from which you can access it is <your-username>.github.io/<your-repo-name>

Highlighted
Ground Controller Lvl 1
Message 24 of 29

Re: pages user site not published

I had this issue and the culprit turned out to be that I had created a repo just before with the same name and then deleted it. When I renamed the repo of interest the live page loaded up just fine.

Highlighted
Copilot Lvl 2
Message 25 of 29

Re: pages user site not published

I have the same problem that a lot of people are having, but don't see how it is getting fixed.

I was hoping to use the address <username>.github,io,

I first tried creating the pages in a repository called /docs, but under settings -> GitHub pages -> Source,

the option to use docs as the source was greyed out.  Then I tried creating a repository

<username>.github.io, and when I do that, under settings -> GitHub pages -> Source, rather than

giving me a menu, it says that "Your GitHub Pages site is currently being built from the master branch"

and above that it says "Your site is ready to be published at http://<username>.github.io/"

Sounds good, but when I click that link I get a 404 page.  I'm sure I'm missing something

(maybe "ready to be published" is different that "published" and I need to do something else),

but I don't know what.

Any ideas?

 

Highlighted
Copilot Lvl 2
Message 26 of 29

Re: pages user site not published

Well, never mind.

After I changed the name to my repository, I had to make a commit before it would get published.  But not it's up.

Highlighted
Copilot Lvl 2
Message 27 of 29

Re: pages user site not published

Did you figure out the issue? I'm having the same one :O

Highlighted
Copilot Lvl 2
Message 28 of 29

Re: pages user site not published

I assume you were able to push the code successfully to the repo.

Make sure the following things are in place:
1. Angular Cli Version should be 8+.
2. Repo should be public and not private - navigate to settings and change the repo to public.
3. Try the following command: ng deploy --repo=https://github.com/<userID>/<repoName> --base-href=https://<userID>.github.io/<repoName>/

In the settings page, you'll get the generated link.
Check the network tab to see if the bundles are being loaded successfully, else clear the cache once and try : ctrl + shift + R.

Highlighted
Ground Controller Lvl 2
Message 29 of 29

Re: pages user site not published

I also had the same problem like this last week and when using an incognito mode, everything was fine.

..