Help
cancel
Showing results for 
Search instead for 
Did you mean: 
Copilot Lvl 2
Message 1 of 4

UPDATE: FIXED Jekyll site builds locally but looks odd with no errors on Github pages

Solved! Go to Solution.

Hello,

 

I am trying to build a site using Jekyll and Github pages. Everything seems okay locally but when I push to git and navigate to it the website looks a mess. Unfortunately I don't seem to be getting any build errors in order to diagnose.

 

The github repo and website here.

 

I'm a html newbie - I built the site by forking a theme (herring cove) and then hacking about to get things to look as I wished. I'm hoping it's something simple but am at a bit of a loss at the moment with no errors to go on.

 

Many thanks in advance,

 

Mark

 

P.S. If you don't have time to reply but know what to google in order for me to debug please let me know (as in, I don't even know what to call the 'error' when searching).

3 Replies
Highlighted
Moderator
Message 2 of 4

Re: UPDATE: FIXED Jekyll site builds locally but looks odd with no errors on Github pages

Hi @maw501,

I'm so glad you were able to find a solution to your question! If you could, would you please comment here letting us all know how you fixed the problem? The information could be really helpful to other GitHub users if they run into the same question. Thanks!

Mark helpful posts with Accept as Solution to help other users locate important info. Don't forget to give Kudos for great content!

Highlighted
Solution
Copilot Lvl 2
Message 3 of 4

Re: UPDATE: FIXED Jekyll site builds locally but looks odd with no errors on Github pages

Hi @nadiajoyce,

 

I am not fully sure what the issue was though I think it related to having a different set-up locally to what is used by github-pages. I followed instructions here to update my local environment to the correct gem (which itself threw errors I can't recall - though I was able to google my way out of them).

 

Thanks

Highlighted
Moderator
Message 4 of 4

Re: UPDATE: FIXED Jekyll site builds locally but looks odd with no errors on Github pages

Thanks so much, @maw501! I'm sure this will help others :)

Mark helpful posts with Accept as Solution to help other users locate important info. Don't forget to give Kudos for great content!