Help
cancel
Showing results for 
Search instead for 
Did you mean: 
Copilot Lvl 2
Message 1 of 3

My page shows fine locally but on github the theme is gone and the links are broken

Solved! Go to Solution.

hi, its the first time Im doing this and I followed this guide using jekyll: 

https://medium.com/20percentwork/creating-your-blog-for-free-using-jekyll-github-pages-dba37272730a

 

The website works fine hosted on my localhost but look how broken its on github:
https://rastiazul.github.io/merino/

 

I bet this must be a common noob error but I couldnt find a solution searching the forum.

 

Thank you 

2 Replies
Solution
Commander Lvl 2
Message 2 of 3

Re: My page shows fine locally but on github the theme is gone and the links are broken

If you look at the page source, the style sheet links to 

href="/assets/main.css"

but that file doesn't exist, so that is not the location in the github repository.

 

Either you need a folder named "assets" in the github repository, and main.css in that folder, or you need to fix the web files to point to where the main.css file actually is.

 

Please follow-up to let us know how you made out. For good karma, mark a reply as the answer if it helped!

Ground Controller Lvl 2
Message 3 of 3

Re: My page shows fine locally but on github the theme is gone and the links are broken

I'm having the same issue. I'm not sure if your reply applies to my site as well, but I did try to add body tags in my index.html file, it's not working still.

 

My site serves right locally, but the github pages version does not show the correct theme, and rather an unstyled website. In my repo's settings, it says the theme that I want is being used, however, it is not displayed.

 

https://reganconnell.github.io/regan-connell/

Here's my repo: https://github.com/reganconnell/regan-connell