Help
cancel
Showing results for 
Search instead for 
Did you mean: 
Ground Controller Lvl 1
Message 1 of 5

404 error

Hi all, 

 

I've been trying to publish my page on Git Hub pages. Unfortunately I keep getting 404 error. 

and Git hub pages link: https://pat-cki.github.io
I keep getting an error in the console about favicon but removing it did not help. 
Also clearing cache does not seem to change anything.
 
Any help or suggestions would be appreciated. I've never have done this before.
 
thanks,
Pat
4 Replies
Pilot Lvl 1
Message 2 of 5

Re: 404 error

Yes I have confirmed and descending code (3) has got address (@),this item should not be scanned externaly it should be cloned inside contribute sections when filling including others. This will make and assist README to auto arrange content and console to be in proper mode.But its better to test required before filling. I know it is headache work but practice makes perfect. Try to remove external email address to allow link runner to read cess. Otherwise thanks for you alerts,keep on like that .
Thanks.
Highlighted
Pilot Lvl 1
Message 3 of 5

Re: 404 error

When you open node address instead of going to owner,it open second console which means you are using combined articles inside address why?. Okay anyway try to recorrect it I will be on you back when you focus on it.
Commander Lvl 2
Message 4 of 5

Re: 404 error

I believe if you drop the leading "./" from the all.css and favicon.ico references, they'll start working.  As to why "favicon.ico" is still referenced despite the removal, I have no idea!

 

But it may not be that simple, so here are some alternative discussions.

Related info

Please follow-up to let us know how you made out. For good karma, mark a reply as the answer if it helped!

Commander Lvl 2
Message 5 of 5

Re: 404 error

Confirmed in a fork, the following works better:

    <link rel="stylesheet" href="node_modules/@fortawesome/fontawesome-free/css/all.css">
    <link href="https://fonts.googleapis.com/css?family=Roboto+Mono&display=swap" rel="stylesheet">
    <link rel="stylesheet" href="style.css">
    <link rel="shortcut icon" type="image/x-icon" href="favicon.ico">    

The link to all.css still gives me a 404 error, I suggest simplifying the deep path.

 

When I had no favicon.ico link, github pages still seems to be trying to load one by default. You might want to follow-up with the github team if this is a problem.

 

Please follow-up to let us know how you made out. For good karma, mark a reply as the answer if it helped!