Help
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Copilot Lvl 2
Message 1 of 2

Container is not running

I have a ci file


 
name: CI

on: [push]

jobs:
  build:
    runs-on: ubuntu-latest
    strategy:
      matrix:
        php: [5.6, 7.0, 7.1, 7.2, 7.3]
    container:
      image: php:${{ matrix.php }}-alpine
    steps:
    - uses: actions/checkout@v1
    - name: Show php version
      run: php -v
    - name: Install composer
      run: apk add wget && wget -qO- https://getcomposer.org/installer | php -- --install-dir=/usr/local/bin --filename=composer;
    - name: Install dependencies
      run: composer install --prefer-source
 



And on step Show php version error occured Error response from daemon: Container affade1e9552fd8565103588880dffc890da1c997494f05df43e7ec32c12b569 is not running

How I can solve this problem?

1 Reply
GitHub Staff
Message 2 of 2

Re: Container is not running

We currently do not support Alpine containers for job level containers.  You will need a container that is capable of running the standard linux distribution of node.  We are working on changes to enable use of alpine based containers.