Help
cancel
Showing results for 
Search instead for 
Did you mean: 
Copilot Lvl 2
Message 1 of 7

"Sorry, something went wrong. Reload?" after creating my first action

I tried making my first GitHub action here:

    https://github.com/spack/spack/pull/12269.

 

The action looks at who modified certain files in a pull requet, then adds them as reviewers.  Note that, yes, this is *like* the CODEOWNERS, but we want package maintainers to be able to add their names to a maintainer list in their own package.py files instead of always updating a single file.

 

I added my action to main.workflow and attempted to trigger it with a pull request here:

    https://github.com/spack/spack/pull/12269

 

Now, my Actions tab doesn't work and just says "Sorry, something went wrong. Reload?".  I'm not sure how best to get debug output from the actions, or how to understand what's wrong.  Any pointers?

 

Screen Shot 2019-08-04 at 10.26.40 AM.png

6 Replies
Copilot Lvl 2
Message 2 of 7

Re: "Sorry, something went wrong. Reload?" after creating my first action

Noticed the same thing as well today in a brand new action.

Copilot Lvl 2
Message 3 of 7

Re: "Sorry, something went wrong. Reload?" after creating my first action

+1 brand new action and stuck on reload (for what it worth :  the initial commit had been overwritten)

Copilot Lvl 2
Message 4 of 7

Re: "Sorry, something went wrong. Reload?" after creating my first action

Same problem here. At first I thought it was due to bad formatting of my workflow, but when I revert to a known working revision, the problem persists.

Copilot Lvl 2
Message 5 of 7

Re: "Sorry, something went wrong. Reload?" after creating my first action

Did you find any solution for this?

Copilot Lvl 2
Message 6 of 7

Re: "Sorry, something went wrong. Reload?" after creating my first action

Incredibly frustrating ... Can't do any testing when this happens... No known solution and there's been no word from any Github employees.

Copilot Lvl 2
Message 7 of 7

Re: "Sorry, something went wrong. Reload?" after creating my first action

our repo migreted to the new system uning `yml` and now it works just fine :)