Use Grails 2.5.5 with Github Actions

I was trying to install grails 2.5.5 using sdkman and java 8 but i don’t know how to do this, i was finding information, with my best try i was just allowed to install java 8, but i can’t use the command sdk to install grails or groovy, i am very confused.
I tried also to follow a tutorial that uses grails 4, but was not useful because that do all with gradle and grails 2.5.5 cant use that tutorial.
Someone can help me?