Tab completion in the issue/PR comment editor appears broken

We have several teams in our organization (plotly), and I often tag @plotly/devops in issue or PR comments. Up until about a week ago I was able to do this by typing @plotly/dev[TAB] but now it autocompletes to @plotly/dash. Even @plotly/devop[TAB] ends up as @plotly/dash. Thinking it might be trying to match on the description of the team, I added a space to the @plotly/dash description but it still completes to @plotly/dash.

Is there anything I can do to restore the tab completion behaviour I expect?

Screen Shot 2019-04-11 at 10.54.45.png

2 Likes

Thanks for the feedback.

What happens if you type @plotly/do? It appears to be matching using a fuzzy search pattern. In other words, you can type any sequence of characters as long as they’re in the right order.

As for the current behavior, I’ll pass along the feedback to the developers. I can’t give a timeline of when it might get addressed, but I’ll let the right people know about the experience.

Thanks again for your help!

Thanks for the reply!

@plotly/do” matches “@plotly/dash-core Dash Core Team” first. “@plotly/devops” is 5th on that list.

Screen Shot 2019-04-16 at 14.38.12.png

Thanks for passing on my feedback. Fuzzy searching makes sense, but given that an exact match exists I’d expect that to be the first thing shown.

@scjody It appears that this has been fixed, or at least improved. Give it a try!

Looks good now. Thanks for the update, and thanks to whoever made the change!

Screen Shot 2019-04-30 at 15.45.34.png

1 Like