Securing your Workflows Course - No vulnerable dependencies

Hello,

I’m attempting to find my repo’s vulnerabilities according to these instructions:

  1. Click the Insights tab in your repository.
  2. On the left hand navigation bar, click Dependency graph.
  3. Scroll down until you see a yellow bar highlighting the dependency named debug, and click on the right hand side of the yellow debug section.
  4. Take note of the suggested version.
  5. Comment in this issue with the suggested update version.

However, I do not see any vulnerabilities! See photo below.

I was expecting visionmedia/debug to have a yellow bar. Have I done something wrong?

Thank you in advance.

Hello Drew.  We have corrected this issue. You may need to de-register and restart the course to see the correction.  Please let me know if you continue to encounter this issue.  Thank you!

1 Like

Hello,

It works perfectly now. Thank you so much.

Hello,
I am getting the same issue.

1 Like

Same issue here. I don’t see any yellow bar.

It seems it’s still an issue.
Even though version is shown as 2.6.8 (lesser than in original issue), github doesn’t show it as vulnerable.

This Issue still doen’t seem to be resolved. I have de-registered and re-registered several times now, still not able to see vulnerabilities. Not sure if this is now elsewhere now or not.

Hello all,
This course was recently updated to use the default branch name “main” instead of “master”. When you re-registered, did you delete your repo? If not, can you try that and let me know if this resolves the issue?
Thanks,
Lia

1 Like

Hello, I am having this same issue. Anyone else managed to solve it?

2 Likes

Hello everyone, I am facing the same issue. Is there anything that can be done about it?
@lmkeston could you please suggest what should be done about the same?