rack-test-0.8.3 requires ruby version >= 2.2.2, which is incompatible with the current version, ruby

I’ve connected my pages site to travis.cl because it seems to be the only way to figure out what is going on.  My local build is working just fine, but when I push the pages site to my repo, I get the following error in the Travic.CL log:

rack-test-0.8.3 requires ruby version >= 2.2.2, which is incompatible with the
current version, ruby 2.1.10p492

Any idea what this would be and how to fix it?  I don’t know what rack-test-0.8.3 is nor why it’s suddenly being referenced at all.

This message is emitted by Bundler, I believe. Bundler is used to install and manage the dependencies of a Ruby project, like Jekyll, the software that GitHub Pages runs on. rack-test-0.8.3 is almost certainly a transitive dependency of Jekyll or GitHub Pages’ configuration and ruby 2.1.10p492 is most likely Travis’ default version of Ruby unless you specify otherwise in your travis.yml.

That’s just an educated guess though. If your Pages repo is public and you can share a link to it, we could possibly investigate a little further.