Please support poetry for dependancy graphs in python repos

github automatically shows dependency graph for python projects with a requirements.txt

we can see who is using a project, and also all the dependencies of a project.

but poetry (15.1k stars) is used by many people, and github does not support pyproject.toml and poetry.lock

also see

dependabot supports poetry. see Configuration options for dependency updates:

For package managers such as pipenv and poetry , you need to use the pip YAML value. For example, if you use poetry to manage your Python dependencies and want Dependabot to monitor your dependency manifest file for new versions, use package-ecosystem: "pip" in your dependabot.yml file.

1 Like