Pipelines deploying the Angular code failing at NPM installation

Hello Team,

All our pipelines were working fine till 06/Sept/2021.
Recently, we started facing this issue at the step when we install the NPM packages before the Angular artifact is generated. There have been no change in the pipeline yaml files.

  1. We tried to clear the npm cache before installing the NPM during pipeline run, but still no luck.
  2. We tried to replace the npm command with the below -
    npm install -g npm@latest

This resulted in successful execution of NPM Install step but failed during the building of app.
ng build --target=production --environment=dev --base-href=/ofp/

========================== Starting Command Output ===========================

“C:\Windows\system32\cmd.exe” /D /E:ON /V:OFF /S /C “CALL “D:\a_temp\e01f3397-0a1b-4e98-9b1a-298bb32e8a11.cmd””

No projects support the ‘build’ target.

Requesting some inputs/pointers on the issue. Thanks!

Pipeline Error
“C:\Windows\system32\cmd.exe” /D /E:ON /V:OFF /S /C “CALL “D:\a_temp\d87f59c9-0b21-457d-aa79-f280eea09f04.cmd””

npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797)

npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:

npm ERR! <https://npm.community>

npm ERR! A complete log of this run can be found in:

npm ERR! C:\npm\cache_logs\2021-09-08T09_26_03_098Z-debug.log

##[error]Cmd.exe exited with code ‘1’.