page went blank on private browsing angular

Hi everyone, I have a problem that need to solve in angular 6 app. There is problem where I went on to private browsing the page logs find but when I click on other link, the page went blank. That’s where I went on an restart the server, the page appeal. When I went for normal browsing the page loads find. 

I went on test on IE even got worst, it does not load at all. Below is the screenshot of both IE and chrome that I have capture, I also include the error codes capture by the developer too of each browser.

Chrome Error Code:

jquery-migrate.min.js?ver=1.4.1:2 JQMIGRATE: Migrate is installed, version 1.4.1
jquery.min.js:2 Uncaught TypeError: e.indexOf is not a function
at w.fn.init.w.fn.load (jquery.min.js:2)
at general.js:606
at general.js:650
core.js:3123 Angular is running in the development mode. Call enableProdMode() to enable the production mode.
zone.js:192 Uncaught ReferenceError: autosize is not defined
at HTMLDocument.<anonymous> (general.js?ver=1.1:601)
at l (jquery-3.3.1.min.js:2)
at c (jquery-3.3.1.min.js:2)
at ZoneDelegate.push…/node_modules/zone.js/dist/zone.js.ZoneDelegate.invokeTask (zone.js:421)
at Zone.push…/node_modules/zone.js/dist/zone.js.Zone.runTask (zone.js:188)
at push…/node_modules/zone.js/dist/zone.js.ZoneTask.invokeTask (zone.js:496)
at ZoneTask.invoke (zone.js:485)
at timer (zone.js:2054)

IE error code:

HTML1300: Navigation occurred.
File: localhost:4200
JQMIGRATE: Migrate is installed, version 1.4.1
SEC7113: CSS was ignored due to mime type mismatch
File: bootstrap.min.js
SCRIPT438: Object doesn’t support property or method ‘isFrozen’
File: polyfills.js, Line: 13906, Column: 5
SCRIPT438: Object doesn’t support property or method ‘isFrozen’
File: polyfills.js, Line: 13906, Column: 5
SCRIPT5009: ‘autosize’ is undefined
File: polyfills.js, Line: 11880, Column: 25

I just started learning angular so hope you don’t penalise me on this. I try to post the code here but problem is I don’t know where to start. Could your help me on this, I try to post the code as your have requested. Thanks

But it does work on non-private browsing in Chrome?

IE is pretty dead, so I wouldn’t expect a lot from it. If you really need support for it read this: https://blog.angularindepth.com/angular-and-internet-explorer-5e59bb6fb4e9.

I too faced the similar issues before. In my case it was because of chrome extensions which I enabled in the incognito window. 

  1. You can remove the complete node_modules folder 

  2. then do the npm install 

  3. Mostly it will load, if not hit the ctrl + f5 (hard refresh)- possibly because of cache 

Let me know if this solution has helped.