No matching distribution found for torch==0.4.1

I’m trying to run my CI job (link) against an older version of PyTorch (0.4.1) but I get the following error message when running pip install torch==0.4.1:

ERROR: Could not find a version that satisfies the requirement torch==0.4.1 (from versions: 0.1.2, 0.1.2.post1, 0.1.2.post2, 1.4.0, 1.5.0)
ERROR: No matching distribution found for torch==0.4.1

Here’s the full log from the CI

Seems like github actions only has really old (0.1.2) or the newest versions (1.4.0 and 1.5.0)…is this right? If so, anyway to work around it?

Thanks

If anyone faces this problem, the solution is changing the pip install command to:
pip install torch==0.4.1 -f https://download.pytorch.org/whl/torch_stable.html

4 Likes