Need help using my first api

Hello, I’m trying to use an api for gameflip to post sales listing, im a seller.

https://github.com/gameflip/gfapi is the api that gameflip provides.  These are the commands : https://gameflip.github.io/gfapi/. 

I’m trying to use an api to help me post listings faster as it ends up being very tedious to do it all manually. And I have over a hundred listings and they need to be reposted every few days so they don’t end up at the bottom of the marketplace.

Okay so I have Git installed, NodeJS V12.13.X LTS, and Python 2.7.14 as listed in the GFAPI I gave. I did the git clone and CD’d to the gfapi and I’ve tried to do the npm install command, this is what happens.

I’ve done 

I’ve done 

SET GFAPI_KEY=<my_api_key>
  SET GFAPI_SECRET=<my_api_secret>

the above with my key and secret provided by the Gameflip website and I have no problem with that, but  I get this

, I open the log and get this:

0 info it worked if it ends with ok
1 verbose cli [
1 verbose cli 'C:\\Program Files\\nodejs\\node.exe',
1 verbose cli 'C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli 'install',
1 verbose cli "'gameflip/gfapi'"
1 verbose cli ]
2 info using npm@6.12.0
3 info using node@v12.13.0
4 verbose npm-session b6ffae8b3a475858
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 silly fetchPackageMetaData error for github:'gameflip/gfapi' Error while executing:
7 silly fetchPackageMetaData C:\Program Files\Git\cmd\git.EXE ls-remote -h -t ssh://git@github.com/'gameflip/gfapi'.git
7 silly fetchPackageMetaData
7 silly fetchPackageMetaData fatal: remote error:
7 silly fetchPackageMetaData is not a valid repository name
7 silly fetchPackageMetaData Email support@github.com for help
7 silly fetchPackageMetaData
7 silly fetchPackageMetaData exited with error code: 128
8 timing stage:rollbackFailedOptional Completed in 0ms
9 timing stage:runTopLevelLifecycles Completed in 1164ms
10 verbose stack Error: exited with error code: 128
10 verbose stack at ChildProcess.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\pacote\lib\util\finished.js:12:19)
10 verbose stack at ChildProcess.emit (events.js:210:5)
10 verbose stack at maybeClose (internal/child_process.js:1021:16)
10 verbose stack at Socket.<anonymous> (internal/child_process.js:430:11)
10 verbose stack at Socket.emit (events.js:210:5)
10 verbose stack at Pipe.<anonymous> (net.js:658:12)
11 verbose cwd C:\Users\AksharShah\gfapi
12 verbose Windows_NT 10.0.18362
13 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "'gameflip/gfapi'"
14 verbose node v12.13.0
15 verbose npm v6.12.0
16 error Error while executing:
16 error C:\Program Files\Git\cmd\git.EXE ls-remote -h -t ssh://git@github.com/'gameflip/gfapi'.git
16 error
16 error fatal: remote error:
16 error is not a valid repository name
16 error Email support@github.com for help
16 error
16 error exited with error code: 128
17 verbose exit [1, true]

I tried to do the npm install command directly to the repository but get this:

If I just open GIT CMD and do “npm install https://github.com/gameflip/gfapi” then I get this

a17c1c75a00e039acdf787d7299ed17d.png.

I run into errors every thing I try to do, how do I post listings and get the build running for the api so I can do these commands?

On this directory 

C:\Users\AkshaarShaah>

try  : npm install ‘gameflip/gfapi’