My web site loses formatting after uploading

I am new to coding and have created a web page using HTML and CSS. It looks good locally in 3 different browsers but when I upload the files here my page loses formatting -fonts, colors, alignment. Everything becomes left-aligned.

Also, I pasted the code into CodePen and it looked good there too.

Any help would be appreciated!

Hello @PapaTuck! Welcome to the community; we are glad to have you here. Can you tell us more about the overall setup or file structure of your CSS and HTML files in that new repository?

If it is a public repo and you are comfortable sharing - then you can share that link here for eyes from the community. In general, you will want to be sure that your CSS is being called from the correct location. Here is a previous example on the forum, although it may not be the same issue in your case: Codepen to Github CSS not applying

Thanks for the info and for getting back with me. I’ll be putting the site back up shortly. I’ll check out the CSS link and see if that does the trick. If not, I’ll share a link.

Thanks so much for sharing that. I noticed that https://papatuck.github.io/css/styles.css loads with a 404 but https://papatuck.github.io/CSS/styles.css shows a listing of CSS.

You may want to the change the uppercase/lowercase matching between the styles.css folder name and the href link in the tag of your index.html file. Does that help?

:+1: Absolutely! I didn’t notice the folder name case being different than the link.

1 Like