Missing icons in codespace

I opened a new codespace and none of the icons populated.

  • Browser [e.g. chrome, safari]: Chrome
  • Version [e.g. 22]: Version 87.0.4280.88 (Official Build) (64-bit)Describe the bug
1 Like

@savannahostrowski, do you see any errors in the console when this happens?

@legomushroom can you help take a look?

1 Like
[Client V] Initializing authentication
[Authentication V] Attempting to load session - login = false
[Authentication V] Attempting to load session - login = true
[Authentication V] Attempting to load session - login = false
[Authentication V] Successfully loaded session
[Authentication V] Successfully loaded session
[Authentication V] Successfully loaded session
[Authentication I] Successfully signed in
[RemoteExplorer I] Updating codespace details
[RemoteExplorer I] Updating codespace performance info
[Client I] Connecting to current codespace: #####
[Command:Connect I] Decorator starting: ErrorNotification
[Command:Connect I] Decorator starting: Telemetry
[Connect I] Connecting to environment: {"environmentId":"###","isRunningInWeb":true,"initialConnectionToCurrentEnvironment":true,"hasResolver":true}
[Client I] Monitoring git changes
[RemoteExplorer I] Updating codespace details
[RemoteExplorer I] Updating codespace performance info
[Connect V] Connecting extension to current codespace.
[RemoteExplorer I] Updating codespace details
[RemoteExplorer I] Updating codespace performance info
[WorkspaceApi V] get workspace info -> https://prod.liveshare.vsengsaas.visualstudio.com/api/v1.2/workspace/##
[FetchRequest:1 V] GET - fetch start
[FetchRequest:1 V] GET - fetch response. (url=https://prod.liveshare.vsengsaas.visualstudio.com/api/v1.2/workspace/##;status=200)
[WorkspaceApi V] get workspace access -> https://prod.liveshare.vsengsaas.visualstudio.com/api/v1.2/workspace/##/user
[FetchRequest:2 V] PUT - fetch start
[FetchRequest:2 V] PUT - fetch response. (url=https://prod.liveshare.vsengsaas.visualstudio.com/api/v1.2/workspace/##/user;status=200)
[WorkspaceClient V] connecting to relay link:sb://vsls-prod-ins-usw2-private-relay.servicebus.windows.net/##
[WorkspaceClient V] creating node SSH...
[WorkspaceClient V] authenticating...
[WorkspaceClient I] join: ##
[WorkspaceClient V] < version.exchangeVersions()
[WorkspaceClient V] > version.exchangeVersions() succeeded t:6.0
[WorkspaceClient I] Host version: {"version":"1.0.3404.8154","protocolVersion":"2.2","platformName":"Linux 5.4.0","platformVersion":"5.4.0.1031"}
[WorkspaceClient V] < workspace.joinWorkspace()
[WorkspaceClient V] > workspace.servicesChanged: 
[WorkspaceClient V] > workspace.progressUpdated: 
[WorkspaceClient V] > workspace.joinWorkspace() succeeded t:6.0
[WorkspaceClient I] joinWorkspace -> time:20.0 session:6 conversation:##
[WorkspaceClient I] join completed workspace:## -> time:1097.0
[WorkspaceServices V] Registering ServerSharingService event handlers.
[WorkspaceServices V] < IVSCodeServerHostService.getCodespaceStateFilePath()
[WorkspaceServices V] < serverSharing.getSharedServers()
[WorkspaceServices V] < sourceEvent.fireEvent()
[WorkspaceServices V] > sourceEvent.event: 
[WorkspaceServices V] > sourceEvent.fireEvent() succeeded t:11.0
[WorkspaceServices V] > file.externalFilesChanged: 
[WorkspaceServices V] > serverSharing.getSharedServers() succeeded t:11.0
[WorkspaceServices V] > IVSCodeServerHostService.getCodespaceStateFilePath() succeeded t:12.0
[WorkspaceServices V] < file.readText()
[RemoteResolver I] Adding '/home/codespace/workspace/hello-vscodespaces' to the recent paths list.
[Command:Connect I] Command [Connect to Codespace]: Connect to Codespace Success (3561ms)
[Command:Connect I] Decorator finishing: Telemetry. Duration: 1ms (0 + 1)
[Command:Connect I] Decorator finishing: ErrorNotification. Duration: 0ms (0 + 0)
[WorkspaceServices V] > sourceEvent.event: 
[WorkspaceServices V] > file.readText() succeeded t:48.0
[WorkspaceServices V] < IVSCodeServerHostService.getDevcontainerStateFilePath()
[WorkspaceServices V] > file.externalFilesChanged: 
[WorkspaceServices V] > IVSCodeServerHostService.getDevcontainerStateFilePath() succeeded t:4.0
[WorkspaceServices V] < file.readText()
[WorkspaceServices V] > file.readText() succeeded t:2.0

Here’s the entire output window log with some IDs redacted with ###

Thanks for sharing! Sorry for the confusion, but I meant the browser console via F12 tools. I would expect to see some errors in there if the connection to load icons from the backend failed.

Oh duh :slight_smile:. My bad haha

There is an error!

Uncaught DOMException: Failed to execute 'importScripts' on 'WorkerGlobalScope'

I had this issue a few days ago a the same time as the “AMD Loader” issue. Both were improved by force refreshes. Seem to be completely resolved now, as something seems to have been addressed on the back end.

1 Like