Linux CentOS error msg- invalid version flag: or

I have an error when attempting to install GitHub Desktop from shiftkey/desktop for Linux CentOS 7. After setting up the package repository, I attempted to run the sudo yum install github-desktop command and result in this following error: invalid version flag: or. Is there a way to resolve this issue?