Having trouble with Flake8 Installation (ATOM)

Hello i’m a student who just started a bachelor in informatic so i was trying to learn a bit before my very first lesson. So yesterday night,**  I was installing Flake8 and Linter for Atom when I type Python but I am getting these errors**

[Linter] Error running Flake8
See Console for more info. (Open View -> Developer -> Toggle Developer Tools)

So I checked the console and I see this whenever I get the error
[Linter] Error running Flake8 Error: /Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/pycodestyle.py:113: FutureWarning: Possible nested set at position 1
EXTRANEOUS_WHITESPACE_REGEX = re.compile(r’[[({] | []}),;:]’)
at ChildProcess.<anonymous> (/Users/InsertNameHere/.atom/packages/linter-flake8/node_modules/sb-exec/lib/index.js:56:20)
at emitTwo (events.js:126:13)
at ChildProcess.emit (events.js:214:7)
at maybeClose (internal/child_process.js:925:16)
at Socket.stream.socket.on (internal/child_process.js:346:11)
at emitOne (events.js:116:13)
at Socket.emit (events.js:211:7)
at Pipe._handle.close [as _onclose] (net.js:554:12)

I think it’s bc during the installation i clicked on a cancel at some time but i don’t know if it’s possible to reinstall or fix this mistake

**I do have some other packages installed but I dont know if one of them are causing the issue.

I am trying to learn Python so if someone knows how to fix this it would be great help!**

Thx for your help !!!

Edit: I don’t really know if my topic is in the right spot and apologize in advance if it isn’t. I didn’t know where to ask since i’m new here