Having trouble generating installation access token with installation id

Hello, I’m having trouble following the instructions here:

https://developer.github.com/apps/building-github-apps/authenticating-with-github-apps/#authenticating-as-an-installation

I’m able to successfully get a response when I hit the route:

https://api.github.com/app/installations/:installation_id

I get the following response:

{
  "id": 754036,
  "account": {
    "login": "hamelsmu",
    "id": 1483922,
    "node_id": "MDQ6VXNlcjE0ODM5MjI=",
    "avatar_url": "https://avatars2.githubusercontent.com/u/1483922?v=4",
    "gravatar_id": "",
    "url": "https://api.github.com/users/hamelsmu",
    "html_url": "https://github.com/hamelsmu",
    "followers_url": "https://api.github.com/users/hamelsmu/followers",
    "following_url": "https://api.github.com/users/hamelsmu/following{/other_user}",
    "gists_url": "https://api.github.com/users/hamelsmu/gists{/gist_id}",
    "starred_url": "https://api.github.com/users/hamelsmu/starred{/owner}{/repo}",
    "subscriptions_url": "https://api.github.com/users/hamelsmu/subscriptions",
    "organizations_url": "https://api.github.com/users/hamelsmu/orgs",
    "repos_url": "https://api.github.com/users/hamelsmu/repos",
    "events_url": "https://api.github.com/users/hamelsmu/events{/privacy}",
    "received_events_url": "https://api.github.com/users/hamelsmu/received_events",
    "type": "User",
    "site_admin": true
  },
  "repository_selection": "selected",
  "access_tokens_url": "https://api.github.com/installations/754036/access_tokens",
  "repositories_url": "https://api.github.com/installation/repositories",
  "html_url": "https://github.com/settings/installations/754036",
  "app_id": 27079,
  "target_id": 1483922,
  "target_type": "User",
  "permissions": {
    "issues": "write",
    "pull_requests": "write",
    "app_config": "read",
    "checks": "read",
    "contents": "read",
    "metadata": "read"
  },
  "events": [
    "issues",
    "project",
    "project_card",
    "project_column",
    "pull_request",
    "pull_request_review",
    "pull_request_review_comment"
  ],
  "created_at": "2019-03-16T04:57:54.000Z",
  "updated_at": "2019-03-16T17:03:35.000Z",
  "single_file_name": null
}

however, when I make a POST request to this route:

https://api.github.com/app/installations/:installation_id/access_tokens

I get the following error:

{
  "message": "Not Found",
  "documentation_url": "https://developer.github.com/v3"
}

Does anyone know why this might be happening?  Thank you!

Hi @hamelsmu,

Thanks for reaching out and our apologies for the late response, are you still having issues with this call?