Hello! I’m receiving the following error in my terminal when I attempt to install or update the github-pages gem:
PS C:\Users\maddi\OneDrive\Documents\GitHub\AM-ABROAD\myblog> bundle install
Fetching gem metadata from https://rubygems.org/…
Bundler could not find compatible versions for gem “terminal-table”:
In snapshot (Gemfile.lock):
terminal-table (= 2.0.0)
github-pages (~> 219) was resolved to 219, which depends on
terminal-table (~> 1.4)
minima (~> 2.5) was resolved to 2.5.1, which depends on jekyll (>= 3.5, < 5.0) was resolved to 4.2.0, which depends on
bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
PS C:\Users\maddi\OneDrive\Documents\GitHub\AM-ABROAD\myblog> bundle exec jekyll serve
Could not find gem ‘github-pages (~> 219)’ in rubygems repository https://rubygems.org/ or installed locally.
The source does not contain any versions of ‘github-pages’
bundle install to install missing gems.
Here is my project’s gemfile:
I am building this website using Jekyll so my guess is there must be some dependency issues. I am attempting to host my jekyll site through github pages and I have the repository setup, now all that’s left to do is integrate github pages via the gemfile.
Any help would be greatly appreciated! Thank you