Github has slow response whenever trying to load a [large] code file on the website on Chrome.

 For quite a while, I have been facing this issue. 

Whenever, I open a code file - like this from an open-source project - https://github.com/dusty-nv/jetson-reinforcement/blob/master/gazebo/ArmPlugin.cpp, the website starts to lag and slows down immensely. I can’t effectively scroll down or do anything. Happens with this one too for example - https://github.com/sahiljuneja/Udacity-Deep-Learning-ND/blob/master/P3-Tv-Script-Generation/problem_unittests.py

This issue hasn’t presented itself on Firefox. I am not sure how to diagnose this, so thought of posting here before contacting support directly. 

I tried disabling all extensions on Chrome for github.com and the problem persists. I am not sure if this is relevant, but I also have had issues with lightboxes not loading up properly on Chrome for quite a long time. 

2 Likes

Hi @sahiljuneja,

Those files don’t appear to be too large, and one of our support specialists was able to load them just fine using Chrome. In order to troubleshoot better, can you please reach out to us at https://github.com/contact? We should be better able to help from there.

Thank you @nadiajoyce. Reported it via that contact page!

1 Like

I encountered the same problem exactly. in Chrome only.

2 Likes

Thanks for letting us know. Can you please also write to https://github.com/contact so we can take a closer look. We’re investigating the issue, but it could be helpful to get more detailed information from you privately.

I think the problem is caused by some browser extension. For me the slowdown was because of the Find my bookmarks extension

I am also facing this issue on chrome.

Did you resolve this? It is August 2019, and this is still happening for me…

It seems it was an issue with Chromium itself and not Github or maybe even chrome. I have a UHD screen and a bug in chromium was slowing the browser down for those screens in some cases.

It was fixed a while ago, but I still noticed issues here and there. But the problem was vastly reduced.

I have since moved on to Firefox for most things so it’s not much of an issue for me. But even on Chrome the problem is not as big a deal as it was before the fix.

If you want try to post on the chromium bug tracker with details and maybe they look into it.

We are facing the same issue as well. It is so slow that we litterally have to wait few seconds for any interaction related to review comment on the PR. I am using chrome as well. Any update on this?