Gh pages hasn't deployed my create-react-app and react-router app

Hello everybody, I am new in this community and finally it is this time when I have to ask you for your help. I would like to deploy my practice app in gh-pages. I read instructions how to do it and… it didn’t work. I still looking for a mistake I did but I can’t find it :confused:

In dev tools console i received:
Failed to load resource: the server responded with a status of 404 ()
2.01830e90.chunk.js:1 Failed to load resource: the server responded with a status of 404 ()
main.9bb4cdd3.chunk.js:1 Failed to load resource: the server responded with a status of 404 ()
2.01830e90.chunk.js:1 Failed to load resource: the server responded with a status of 404 ()
main.9bb4cdd3.chunk.js:1 Failed to load resource: the server responded with a status of 404 ()
(index):1 Unchecked runtime.lastError: The message port closed before a response was received.
manifest.json:1 Failed to load resource: the server responded with a status of 404 ()
manifest.json:1 Manifest: Line: 1, column: 1, Syntax error.
main.5646360f.chunk.css:1 Failed to load resource: the server responded with a status of 404 ()
manifest.json:1 Failed to load resource: the server responded with a status of 404 ()

This is link to my github repo of my project:

project repo

Thank you in advance for your help

Hi @KarolChilimoniuk, welcome to the GitHub Support Community! I think this is the same issue as another user was having in this thread here:

It looks like your asset links are missing the ReminderApp section of the URL. You need to follow a few extra steps to get your React app working on Pages, including filling out the homepage variable in your package.json. I’d recommend reading over the instructions here:

I just noticed you have added the homepage variable, but you’ve added it inside the dependencies object instead of on the top level. You’ll need to move that outside of dependencies and into the same level as name.

Sorry for my late response but my Christmas vacation was longer than I supposed :] Thank you for your help. I realised that I made a mistake in my package.json and additionally I read create-react-app documentation carefully in Deployment chapter and I have found a solution of my problem.