Getting an error while accessing git repo

Hi All,
While accessing a git repo by git version 2.11.1 on wkndows, I am getting an error:
“fatal: unable to access ‘https://github.com/xxx/xxx/’: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version”

Can some on please share quick configurations steps to fix this issue.

Hi @nitin-kharat,

This post was moved to a different board that fits your topic of discussion a bit better. This means you’ll get better engagement on your post, and it keeps our Community organized so users can more easily find information.

As you’ll notice, your Topic is now in the How to use Git and GitHub board. No action is needed on your part; you can continue the conversation as normal here.

Let me know if you have any other questions or if I can help with anything else.

Cheers!

Same thing for me for last 3-4 days. Git clients on Windows 7 (CLI/TortoiseGit) returns

fatal: unable to access <repository>: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

On linux (Ubuntu) all is ok.

What was happened with github?

This is happening to me as well.  I’m on Windows 10.0.16299.248 with TortoiseGit 2.6.0.0.

We are also having issues with our Centos 6.7 server running Apache and Git 2.14.1.  We have a seperate conversation started here:
https://github.community/t5/How-to-use-Git-and-GitHub/Server-fetch-not-working-after-crypto-update/m-p/4153#M1328

We just recently deployed a change that disables support for deprecated legacy TLS and SSH algorithms:

https://githubengineering.com/crypto-removal-notice/

Please contact GitHub Support directly via the Contact form at https://github.com/contact. The team there is collecting all the latest information on various configurations and should be able to help you more quickly.