Getting 404 when I click start on Intro to GitHub

@crichid thanks for your reply. I do believe I have the app installed for all repos with full permissions. When I go to try and install again I’m getting a disabled save button which I presume means that it’s already installed. Yet when I go to a repo of mine I see nothing to indicate the lab app.

I have the same issue. 404 error comes up even everything is installed.

@loleadan @omnidk it seems you have both encountered the same weird bug. We were able to reproduce it by switching the installation type from “Selected” to “All” after starting the course. Does that sound familiar?

To fix this, we recommend you leave and re-join the course. To do this:

  1. Access the course page on GitHub Learning Lab

  2. Click the button to Leave course

  3. Choose the option to delete the course repository.

  4. After that process completes, select the option to Join this Course

  5. If you currently have the “Selected” installation type, you will need to install the GitHub Learning Lab app on the github-slideshow repository after it is created in step 4.

Please let me know if you have additional questions!

1 Like

I’ve left, deleted, rejoined and reinstalled but I’m still receiving the same 404 error. - After persevering and deleting and rejoining and reinstalling over 6 times I managed to get access to the course.

1 Like

I’m having this same issue and have for a few months. It doesn’t matter which course I choose or wither I Install GitHub Learning Lab on a single repository or all of them.

I got it to work on about the 10th try…  install on all repos and then went in and modified it to specific repos.  :confused:

1 Like

same issure here, rejoining the course doesn’t help…

Thank you all so much for this feedback!

As a result, we’ve made modifications to Learning Lab and you should no longer see a 404 during installation behavior. If this re-occurs, please let us know and we’ll continue troubleshooting. 

Same issue.

  • Join the markdown course, install Github Learning Labs (GLL) for all repos, 404 on start
  • Leave course, Delete markdown repo, Uninstall GLL from account
  • Rejoin markdown course, Install GLL for markdown course repo, 404 on start
  • Leave course, Delete markdown repo, Uninstall GLL from account
  • Install GLL for all repos, Rejoin markdown course, Install GLL for markdown course repo, 404 on start

I’d really like to check out the modules, but I can’t

¯_(ツ)_/¯

@heymajor I’m sorry you are having problems with starting the course. Do you mind trying a couple things for me?

  1. What happens if you install the app first via https://github.com/apps/github-learning-lab/installations/new and then try to start the course?

  2. Are you able to join any of the other courses?

  • Install Github Learning Labs (GLL) for all repos through link, Join the markdown course, Select “Install GLL on markdown-portfolio”, 404
  • Go back, Select option to “Install on all repos”, 404
  • Access https://lab.github.com/, Select “Introduction to GitHub”, Select “Join this course”, Select “Install GLL on github-slideshow”, 404
  • Go back, Select option to “Install on all repos”, 404

I’ve removed repos/uninstalled GLL

@heymajor you will only need to install the app one time if you are installing on all repositories so I’m curious how you continue to end up on the installation page. Do you mind dropping in some screenshots of what you see as you go through this process? I’m especially interested in what you see after you choose the option to register for the course that is asking you to install the app again.

Thanks for hanging in there - we’ll get this figured out!

Hello, i tried to start my Github Learning Lab Introduction Course  and got a 404 Error after pressing start course button. Can you please help ?

Hi @josh5848,

Since it looks like there’s a number of people having this issue, I merged your post into the active thread so that @crichid can work with you as well.

Thanks! 

@josh5848 it looks like you were able to successfully register and start the course based on your progress in the course repository! Happy learning and let us know if you have any further challenges.

Was there any clue as to why this is happening? I have the exact same issue. Nothing I have tried will get the Introduction to Github to work. I did try another course and it worked. Now I am not sure what state I am in as to whether the lab app is installed or not. I have no repositories now and cannot install the introduction course. If I click “next” I get 404, otherwise is just sits on the “your repository is being set up” page.

Hi @frightrisk! I’m not sure why this is happening, but it does sound very frustrating. I am able to delete your registration with the Introduction to GitHub course, and that should allow you to re-register. Would you be able to try this again, and let us know how it goes?

Answering you in both threads so this may help others. Indeed it seems there was a loop created that would never let me escape to delete the course. I was stuck in a loop. Your magic worked and allowed me to start over with a simple click of 2 buttons; “login with github” and the recommendation on the next screen, “start with the introduction to github”. Thank you!

I’ve been having this same issue.  Hector from the GLL staff deactivated my registration so I could try installing and joining the course again, but now I can’t proceed because I already have the /github-slideshow repository on my account.  Is there any way I can delete this repository and try again?:

Sure @jillonymous, just navigate to the repo by clicking on the title in the red bar that appears, then go to the Settings tab, scroll all the way to the bottom and click the button to delete the repo. Type in the full repo name (including your username in front of it) and that will delete your repo. You should then be able to re-register for the course. Full instructions for how to delete your repo are also available on the GitHub help docs

1 Like