Firebase version incompatibility with nodejs

Hi Github team,

We are deploying our cloud functions to firebase via github actions.
It was working fine till date but now we are getting this error “Firebase CLI v10.0.1 is incompatible with Node.js v10.24.1 Please upgrade Node.js to version >= 12”

The versions on our local machines and firebase console are proper but still we are getting this error.

Help in this regard would be really appreciated as we are not able to deploy our cloud functions via github actions

Thanks and Regards,
Bijli team