Expo-cli installation halted with the error npm ERR! cb() never called!

I tried installing expo-cli but unfortunately it halted with the errors below.

freduah@freduah:~$ npm install -g expo-cli
npm WARN deprecated graphql-tools@3.0.0: This package has been deprecated and now it only exports makeExecutableSchema.\nAnd it will no longer receive updates.\nWe recommend you to migrate to scoped packages such as @graphql-tools/schema, @graphql-tools/utils and etc.\nCheck out https://www.graphql-tools.com to learn what package you should use instead
npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR!     <https://npm.community>

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/freduah/.npm/_logs/2021-09-28T14_47_55_893Z-debug.log
freduah@freduah:~$ 

how do i go about this ?