Dependabot CVE-2021-3281 Remediation ignores older Versions

Hey Github Dependabot Team,

the Dependabot Alert for CVE-2021-3281 states only the remediation for Django 3.1.

Django 2.2 and 3.0 are completely ignored.

Remediation states:

Remediation

Upgrade django to version 3.1.6 or later. For example:

django>=3.1.6

Vulnerable versions: >= 3.1, < 3.1.6

Patched version: 3.1.6

CVE Details:

In Django 2.2 before 2.2.18, 3.0 before 3.0.12, and 3.1 before 3.1.6, the django.utils.archive.extract method (used by “startapp --template” and “startproject --template”) allows directory traversal via an archive with absolute paths or relative paths with dot segments.

Cheers,
Hetti

Hey and welcome @Hetti ! Thanks so much for taking the time to write us about this.

I am not sure the Dependabot maintainers actively read this forum though. Have you considered filing an issue with them directly?

1 Like

Hey @mpboom !

Thank you very much for your response and the pointer where to report that! :slight_smile:
I was really unsure where I could submit this issue and in the end decided to do it here.

Thanks again for the pointer into the right direction. I gonne report it there :slight_smile:

Edit:

Ah I just saw it was reported: CVE-2021-3281 accidentally bumping Django 3.0 to 3.1 when fix exists in 3.0 series · Issue #3340 · dependabot/dependabot-core · GitHub
:slight_smile:

Cheers!

2 Likes