cygheap base mismatch detected

i am Trying to clone a repository using GITHUB desktop and i get these errors, i have installed both versions of cygwin and even replaced cywin1.dll with older and newer versions but still nothing.

thank you in advance 

Hi mightyphumba!

Did you find that this problem was resolved after restarting your machine?

That seems to have fixed it for a lot of people in this stack overflow answer!