Could not find cardview.jar (androidx.cardview:cardview:1.0.0)

My project worked fine but today when I opened that, that has this error, although I didn’t use any cardview. My other project build fine but only that project doesn’t build.

Could not find cardview.jar (androidx.cardview:cardview:1.0.0).

my class path is: classpath ‘com.android.tools.build:gradle:3.5.1’

I have added cardview library manually but it didn’t work too.

I have added

maven { url "https://maven.google.com"}

but it didn’t work too.

I have added cardview library manually but it didn’t work too.

this is my gradle code project level

buildscript { repositories { google() jcenter() maven { url 'https://maven.fabric.io/public'}} dependencies { classpath 'com.android.tools.build:gradle:3.5.1'// NOTE: Do not place your application dependencies here; they belong// in the individual module build.gradle files}}allprojects { repositories { google() jcenter() maven { url 'https://jitpack.io'} maven { url "https://maven.google.com"} maven { url 'https://maven.fabric.io/public'}}}task clean(type:Delete){delete rootProject.buildDir}

and this is my gradle code app level

apply plugin: ‘com.android.application’

android { compileSdkVersion 29 buildToolsVersion "29.0.2" defaultConfig { applicationId "com.intechdev.tcommerce" minSdkVersion 21 targetSdkVersion 29 versionCode 1 versionName "1.0" testInstrumentationRunner "androidx.test.runner.AndroidJUnitRunner"} buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'),'proguard-rules.pro'}}}dependencies { implementation fileTree(dir:'libs', include:['\*.jar']) implementation 'androidx.appcompat:appcompat:1.1.0' implementation 'androidx.constraintlayout:constraintlayout:1.1.3' implementation 'com.google.code.gson:gson:2.8.5' implementation 'io.reactivex.rxjava2:rxjava:2.1.9' implementation 'io.reactivex.rxjava2:rxandroid:2.0.2' implementation 'com.squareup.retrofit2:adapter-rxjava2:2.4.0' implementation 'com.squareup.retrofit2:retrofit:2.6.2' implementation 'com.squareup.retrofit2:converter-gson:2.4.0' implementation 'com.google.android.material:material:1.0.0' implementation 'com.squareup.picasso:picasso:2.71828' implementation 'androidx.exifinterface:exifinterface:1.0.0' implementation 'com.github.tiper:MaterialSpinner:1.3.3' implementation 'de.hdodenhof:circleimageview:3.0.0' implementation 'com.squareup.okhttp3:logging-interceptor:3.2.0' implementation 'com.google.code.gson:gson:2.8.5' implementation 'com.google.android.gms:play-services-auth:17.0.0' implementation 'com.mikhaellopez:circularimageview:4.0.2' implementation "androidx.preference:preference:1.1.0" implementation 'com.android.support:multidex:1.0.3' implementation "com.github.bumptech.glide:glide:4.9.0" implementation 'com.iarcuschin:simpleratingbar:0.1.5' annotationProcessor "com.github.bumptech.glide:compiler:4.9.0" implementation "com.github.firdausmaulan:GlideSlider:1.5.1" api 'com.theartofdev.edmodo:android-image-cropper:2.8.0' implementation 'com.justkiddingbaby:vercodeedittext:1.1.0' implementation 'com.google.android.material:material:1.1.0-beta01' testImplementation 'junit:junit:4.12' androidTestImplementation 'androidx.test:runner:1.2.0' androidTestImplementation 'androidx.test.espresso:espresso-core:3.2.0'}

When I add implementation ‘androidx.cardview:cardview:1.0.0’, android get this error: ERROR: Failed to resolve: androidx.cardview.cardview:1.0.0:
Affected Modules: app

I don’t need to use cardview and my project didn’t have cardview.

no one can help me in stackoverflow

It looks like you got a useful answer on Stack Overflow. Did that work for you? [In case anyone in this community runs into the same problem.]

1 Like

Yes, I removed that library and everything worked fine 

1 Like