CMake Error g++, I have newer file but need path for cmake

I am using suse-leap-42.3. This current version contains gcc 4.9. I cannot replace the system’s 4.9 but  I can run gcc 5.3 or gcc 6.3 from another dir…

I would like to know which version is preferable and is there a path I can install so that cmake won’t look into my system and find the cyrrent 4.9 version.

I will appreciate help.

inq1

This post was moved to a different board that fits your topic of discussion a bit better. This means you’ll get better engagement on your post, and it keeps our Community organized so users can more easily find information. As you’ll notice, your Topic is now in the Project Development Help and Advice board. No action is needed on your part; you can continue the conversation as normal here.

Let me know if you have any other questions or if I can help with anything else.