Can I use package-lock.json v3 with npm 7?

I’m using npm 7 with workspaces. This isn’t supported with with older versions of npm.

If I’m correct package-lock.json v2 is basically v3 with backwards compatibility for v1. This means it’s twice as big.

Can I make npm 7 use package-lock.json v3 instead?

1 Like