Bug: Not choosing any labels

I was looking for issues in some repositiories. I was unaware of the Labels used for filtering and so was exploring them using Labels button. I found this bug, which i couldn’t resolve.

Problem / Bug: There is no way to “not select” a Label after clicking on the Labels button in Issues tab of a repository.

For illustration purpose I am using Tensorflow Repository, however, i have repeated the same issue with numpy repository as well.

When i open the issues tab of the Tensorflow Repository (mentioned before), I am greeted with this.

Now, if i click on the Labels button, and choose a label, I get immediately redirected to the issues tab with the clicked label inserted as the filter.

Now, If i want to add another label, I again, click on the labels button and keep scrolling through the labels. Let’s say I click on the Page 2 and then Page 3.

Now, i don’t want to choose any lable, there is no way to go back to the issues tab directly.

I have to either click on the label (which I don’t want to) or press the back button on the browser repeatedly (go through the stack of webpages opened) till I reach back the issues tab.

If I tap on the Issues button, I am redirected to the issues tab, however, the filters applied get reset to default.
Thus, if I have chosen some labels before, they are removed automatically.

Hi @nshul,

Thank you for being here! We appreciate your time in providing such a detailed report. Thank you. I have a couple of questions that might help us figure out what’s going on here:

  • Does this happen every time you edit a label, or just some times?
  • Do you see the behavior with all browser extensions disabled
  • Can you reproduce just by clicking on Edit for any label on the Issues page for any repository?
  • Have you noticed if this is specific to one browser type? You can see our list of supported browsers here:

https://help.github.com/en/github/getting-started-with-github/supported-browsers

Thanks a lot for replying!
I will answer your questions.

•Does this happen every time you edit a label, or just some times?
Ans: I am not editing any labels. I am just filtering the Issues using the labels. The repository which i have taken as example, isn’t my repository, i was just trying to contribute to it.
And yes, the issue I have described, i experience it every time. I have mentioned two repositories as example.

•Do you see the behavior with all browser extensions disabled
Ans: I tried to reproduce the same issue on my phone which is an iPhone, and i still get the same issues. There are no extensions in my browser on phone.

•Can you reproduce just by clicking on Edit for any label on the Issues page for any repository?
Ans: I haven’t tried editing or creating any new labels. As mentioned before, i am not owner of repository, just some contributor looking for some open issues.

•Have you noticed if this is specific to one browser type? You can see our list of supported browsers here:
Ans: I have noticed this issue/bug on Chrome on Linux and Safari on iPhone.