Browser will not load some urls - CefSharp

The following url is an example or a url, which the Load method of ChromiumWebBrowser instance will not navigate to.

Google Chrome in windows is fine navigating to it, it’s just an audio stream, and most work but some will not. Not even a server error code, it just stays on its current page without any indication Load() was called on it.

 (edit) title edited to include ‘cefsharp’

https://r6---sn-uigxx03-auol.googlevideo.com/videoplayback?pl=17&mn=sn-uigxx03-auol%2Csn-aigllnzd&ip=188.28.102.168&mm=31%2C29&id=o-AN2_S5EeTPRDIBfkvbU2PaKN1o-oMZeXljv8N6Qz1kl5&sparams=clen%2Cdur%2Cei%2Cgcr%2Cgir%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%2Ckeepalive%2Clmt%2Cmime%2Cmm%2Cmn%2Cms%2Cmv%2Cpl%2Crequiressl%2Csource%2Cexpire&itag=140&ms=au%2Crdu&initcwndbps=343750&mv=m&dur=4389.244&mt=1522522283&ipbits=0&key=yt6&c=WEB&ei=C9m_WoqYF4SrW-uUm_gJ&clen=69712377&gcr=gb&source=youtube&gir=yes&mime=audio%2Fmp4&requiressl=yes&keepalive=yes&fvip=13&expire=1522543979&lmt=1508517609957431&signature=D9F570EA8BD797E57519FBBB8372C647B9E87337.3061F8CAD528540E5E6073A6ECED145057D31762&ratebypass=yes

CEF 3.3239.1723.g071d1c1
Chromium 63.0.3239.132
OS Windows
WebKit 537.36 (@76cbfebbcc5236da3346c8389b94b648d36f8be6)
JavaScript 6.3.292.49
Flash 27.0.0.183
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

Hi @tedson007,

Thanks for being part of the GitHub Community Forum! We’re glad you’re here.

I wanted to jump in here, and mention that if you don’t get the help you’re looking for from this particular community, you might want to try getting help somewhere that focuses on Chromium. It’s definitely possible another GitHub user might have run into this same issue and can help, but the GitHub Community Forum focuses primarily on topics related to GitHub. We want to make sure you’re getting the best support you can, but this forum may not be the right place for this particular topic.

Best of luck!

Okay, thanks.

For some reason I thought this was a cefsharp community, google not as great as it likes to think perhaps.

Cheers for taking the time.

1 Like

You bet! And you never know…Chromium is open source, so it’s possible another GitHub user might be able to help here, but regardless, best of luck to you!

Actually I feel I can move on a little here as my problem is with cefsharp https://github.com/cefsharp/CefSharp

So to be clear, I am using cefsharp in a windows forms application

After my issue here https://github.com/cefsharp/CefSharp/issues/2344

I found that the initial problem I was having was actually because of a cef3 binary (chromium) design feature which disallows the inclusion of proprietary codecs which handle mp3 audio streams.

So when I try to navigate the browser to such a stream, the navigation does not occur, but there does not appear to be a way of detecting this in cefsharp.

I’m hoping someone could help me to figure a way to actually detect in cefsharp library, when this happens, when the Load() method does not actually load.

For the benefit of anyone else interested, my workaround it to query page headers to determine if audio is mp3, so I can deal with the issue in code.