Apt-get install qt5-default qt5-qmake qtdeclarative5-dev failing

For the past 5 days our nightly build has been failing with the following error:

Get:98 http://azure.archive.ubuntu.com/ubuntu focal/multiverse amd64 vice amd64 3.4.0.dfsg-1build1 [5038 kB]
Fetched 38.8 MB in 2s (24.2 MB/s)
E: Failed to fetch http://azure.archive.ubuntu.com/ubuntu/pool/main/s/systemd/libudev-dev_245.4-4ubuntu3.7_amd64.deb  404  Not Found [IP: 52.250.76.244 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

We waited for a bit hoping this would get fixed shortly but it seems nobody noticed it. What’s the best way to report it and get it fixed?